[Gadgeteer]4.1、4.2函式庫版本轉換

        如果在網路上看到很棒的code,但是卻是4.1版本的,該怎麼辦?

        
一開始玩gadgeteer時,這真的是一個令人非常頭痛的問題啊!

         
4.1與4.2版本的差別在於「因為模組的新增,所以不再能使用廣義的稱呼來表示模組」,必須用更加詳細的名字來表示一個模組。舉例來說,在4.1版當中的led因為新增的led模組有多種,而我們使用的是可以閃爍多種顏色的multicolorled,所以Led.(4.1)要修正為multicolorLed.(4.2)。同理,display也出了很多個版本,所以Display.(4.1)要改為Display_T35.(4.2)。

          如果不清楚您應該打什麼,可以回到環境建置的畫面,查看所有模組的名稱,或是回到program generated頁面,查看您使用了那些模組以及它的正確名稱。若還是有問題,可能是因為您的子類別功能選錯了,可能同樣為.led,但它的使用功能跟你需要的不符合,可以重新打一次逗號,檢視冒出的建議選項中有沒有符合您需求的項目,並重新點選。

         所以,您有兩種方法可以解決版本轉換的問題,第一個辦法是把找到的程式碼複製貼上到WORD上,用Ctrl+H更改所有的關鍵字(會有一些風險,最好是親自一個一個改),再貼到Visual Studio中。方法二是在開新專案的時候就點選4.1版本,可是這樣永遠不會進步到4.2了!

About CAVEDU 阿吉 - 雜工 (2521 Articles)
CAVEDU 教育團隊 打雜
Contact: Website

Leave a comment

Your email address will not be published.


*